Sunday, 08 September 2019
  5 Replies
  3K Visits
  Subscribe
Hi, I'm building a custom device with your board and buttons.

I saw recently on your YouTube video where you explain the Cherry MX switches that you had some silver ones (small travel ones).

Do you happen to sell those with your custom diode pcb? (or just the PCB and then I can solder my own switches?)

Thank you!
3 years ago
·
#1848
Hi Carlos. We actually have a total of 18 Cherry MX Silver switches in stock right now (they are not listed on our website since we don't have enough for a full KeyMouse set). Is that enough to do your custom device?
3 years ago
·
#1851
Yeah, I just need 5, but I'm thinking of making 2 devices, so I could take 10.

How would I order them?

Thanks!
3 years ago
·
#1852
Ok. We've added the Silver switches to the purchase page at the bottom of the page: https://www.keymouse.com/purchase

We'll remove them from the site after you get some. I hope they work well for you :)
3 years ago
·
#1853
Thank you!

Also, not about the switches, but still about my custom vertical mouse.

I'm not expecting warranty or anything like that because while I don't remember mishandling it, it's still possible I damaged something in the PCB. Just wondering if you can think of something that I'm missing:

The device was working perfectly until recently, when I added some tactile buttons. For some reason the buttons click randomly now every now and then. It's not all the time, but every once in a while I'll try to click or type something and it'll do a key combination because one of the buttons on the device is registering a pressed.

Also, the mouse jumps position from time to time which didn't happen before.

The cables are tight in the device, but I put a layer of electrical tape so the ends of the jumper cables don't touch the board.

I removed the new buttons, and it reduced the glitches quite a bit, but they still happen from time to time, especially the mouse jumping. My guess is that something is not quite being correctly grounded somehow, so inputs are taking some EM interference (floating).


Btw, I'm using rows 1-6 and columns A-D. The extra buttons used columns E and F.

I'll probably order an additional board with those silver switches, because I do want to make 2 devices, so I'll be able to test if I damaged the board. But any help I can get I'll appreciate.

Thank you!

(I included pictures in case you're curious btw)
3 years ago
·
#1855
Thanks for sharing the photos of your custom device. It's cool to see :)

Regarding the PCB, that is strange behavior indeed. My initial gut reaction is that it would be a short in the wires, but if any wires touched the PCB, that could be the cause, also. It may be worth pulling out the PCB just to test single wires connecting row/column for debugging.

We also have a "Main PCB Protector" file that you can 3D print from our public files that covers the PCB and protects it from any wires touching:
https://drive.google.com/drive/u/1/folders/1XNwW8RbjVquB4i2GLoxWZWcTWEEFS7hT
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below.
Supported: gif,jpg,png,jpeg,zip,rar,pdf
· Insert · Remove
  Upload Files (Maximum 2MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.