Tuesday, 28 May 2019
  8 Replies
  3.3K Visits
I'm using my Alphas in mac and i'm experiencing the following issues:

  • Volume up/down (all versions) only trigger volume down, pause the music or do nothing. Pretty unpredictable but mostly it's vol down.
  • I get randomly asked by the OS if I want to shut down, so some kind of odd shortcut is getting triggered by itself. Many times it happens when I use the scroll wheels on the yellow layer (which I programmed to send Ctrl plus left or right arrow, which in mac means to scroll through desktops). But sometimes it happens on other random keypresses.

I updated the firmware on both my devices and it didn't help.
Anyone else experienced this?
3 years ago
Did you make sure to update your firmware on both the Bluetooth Chip and USB chip? Attached is a video link that explains.
1 year ago
I get randomly asked by the OS if I want to shut down, so some kind of odd shortcut is getting triggered by itself.

I'm seeing this too! Both on a 2019 16" MacBook Pro, and on a 2013 11" MacBook Air. Seems to happen randomly while typing, often several times per hour, disrupting what I'm in the middle of typing. (Already happened a couple times while typing this post!) Attaching a screenshot.

Based on https://support.apple.com/en-us/HT201236 it's as though either Control–Power button or Control–Media Eject were being pressed ( "Display a dialog asking whether you want to restart, sleep, or shut down." )

I'm apparently running the latest KeyMouse software ( "Help > Check for updates" results in "No updates available", window title is "KeyMouse Software 2.00" ), and firmware (Bluetooth v71, USB v17T3).

Any help would be much appreciated.

1 year ago
Have you found a way to reproduce this error? We have had this problem on our end in the past. Some customers have downgraded to previous firmware versions to solve this. We will do further testing on our end.
1 year ago
Also, you are running on version 2.00 of the KeyMouse software and the auto-updater wasn't working for some of the earlier versions. There are some versions of the new firmware in the latest software that may also solve your problem.
1 year ago
Unfortunately I do not know minimal reproduction steps either. But good to know you've seen this in the past too. Perhaps you can keep a debug program running that logs the last N events from your KeyMouse, and when you see this occur in the future, you could check for any patterns in the log?

Thank you for advising that the "Check for updates" function was broken in the version of the KeyMouse software I was running. I've just upgraded to the latest version linked from https://www.keymouse.com/download (v2.56) and performed an update to firmware v73. Hopefully that helps!
7 months ago
Just wanted to post back here that, since upgrading to firmware version 73*, I haven't gotten the rogue "Are you sure you want to shut down...?" prompts!

However, the first issue that F W posted about, namely "Volume up/down only trigger volume down, pause the music or do nothing", is still not fixed.

Can anyone on the KeyMouse team reproduce this issue?

Thanks and best wishes.

*(looks like this is still the latest available version for my KeyMouse Alpha 105, according to the latest KeyMouse software version available for this model, i.e. v2.56)
7 months ago
JB for 100 series devices, there is also a firmware update under "Advanced" to update the 8051 USB chip. The latest should be 18. Also, there are multiple versions of "Volume Up" and "Volume Down" depending on your firmware. This is due to some work-arounds we had to do for multimedia keys (kind of evolved over time). Have you tried the other "Volume Up" or "Volume Down" keys? There should be some under "Multimedia" and some more under "Old Firmware".
7 months ago
Thanks, Heber Allred.

When I try the "Old Firmware" versions of the Volume Up and Volume Down keys, those have no effect.

When I try to upgrade the 8051 USB chip to version 18, I get "This step must be performed on a Windows computer" and I only have a Mac, so unfortunately I'm stuck on version 17T3 until it's possible to upgrade this from a Mac.

Please let us know what you suggest and thanks again for your help with this.
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below.
Supported: gif,jpg,png,jpeg,zip,rar,pdf
· Insert · Remove
  Upload Files (Maximum 2MB)
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.