Thursday, 16 December 2021
  19 Replies
  1.9K Visits
I just received my new Keymouse Track (beta).
I found two issues on Linux (Ubuntu 20.04):
+ The device is not recognized on boot. So, I'm not able to navigate the Grub menu.
+ I tried to save a custom layout but I get the error: No KeyMouse Devices Detected

I used it on Windows and I was able to save the custom layout without any problems.
1 year ago
Hi Francisco. My KeyMouse set is working fine on Grub (version 2.02). Strange that it's not recognizing. We're working on an update for KeyMouse Software on Ubuntu, but haven't put it out yet, since it's not behaving as predictably as Windows & Mac when writing to the devices. I'll let you know when we put out another update. We'll work on it some more tomorrow, and if we can get to the bottom of some HID discrepancies, will put out an update soon.
Thank you Heber,

For the moment I'm fine, since I hardly have to switch OS. In the meantime, I can configure the keyboard on Windows.
I'll be waiting for the update.
1 year ago
Hi Francisco. We just uploaded an updated version of the KeyMouse Software for Linux to the download page. For us, it was writing to the devices fine now, and also doing firmware updates. We did have an issue where it had unreliable behavior when writing to the devices while plugged into our external USB hub. We're not sure if it's a bad USB hub or what, but if we plug directly into the computer it was working fine. Does it work for you?
Hi Hebe,
Thank you very much!
I will test and let you know how it goes.
Hi Heber,
I just downloaded the new software for Linux.
I was able to update the firmware on each device. I had to connect each device as main.
I was also able to edit the layouts.
I tested an external USB hub and plugging directly to the computer. Both ways worked fine.
Thank you very much.

The device is still not working with Grub, I'll see if I can find a workaround.

One more little thing, the right trackball does not move smoothly, it gets harder to move in certain spots. I wonder if this would go away with use.
I tried plugging the device to another USB hub and it did not work.
It worked with a powered USB hub and directly to the computer.
Hi Heber,
Is this the right place to report bugs?

I just noticed that the left keyboard does not work when connected as the main device. Only the right one works.
Sorry, my mistake. I was plugging it wrong. Both devices work fine.
1 year ago
Glad it's working. On the trackball, have you tried cleaning out the trackball area? Hopefully it helps. You can use a Q Tip (chop off one end) to pop out the trackball if needed.
Thanks for the video Heber,
The trackball is clean but it still feels harder to move on certain spots.
What is the expected behaviour of Fn Yellow Lock?
Is it a toggle?
In my case it stays in Yellow no matter how many times I press the Fn Yellow Lock key.
I had to program another key to be Fn Default Lock.
Is this expected?
1 year ago
Francisco, yes this is intentional. Pressing FN Lock locks into a layer, and if you want to switch back, you need a key in that layer to FN Lock default or some other layer.
Hi again Heber,
Merry Christmas!
The right track ball, still gets stuck. I cleaned it following the instructions on the video.
Any ideas?
1 year ago
Merry Christmas to you too :)
Just curious, if you swap the trackballs between the left / right hands does it behave better (for the one hand)? I wonder if the obstruction is some inconsistency on the ball itself, or in the KeyMouse housing.
I swapped the trackballs and I get the same results. The right device is always the one getting stuck so I assume the issue is in the KeyMouse housing.
I was able to fix the issue by opening the device and resembling it.
1 year ago
Francisco Fernandez do you have other USB devices working in Grub? If not, you may need to try modifying your handoff settings in the BIOS. If that allows you to function in Grub but takes some other function away, it may be necessary to switch the setting back and reinstall the OS or recompile Grub or something, especially if settings were changed after the initial OS installation. Depending on your motherboard, it may even be possible that some USB ports behave differently than others, so it could also be worth exploring that possibility first. All of this is conjecture on my part, though, so I probably can't really help beyond these initial suggestions.
Hi Dustin,
Thanks for the suggestions. Yes, I have another USB keyboard and it works fine with Grub.
I noticed that it's not only Grub that is not picking up the KeyMouse device. It just isn't recognized by the bios on boot.
For example: pressing F12 to access BIOS does not work. KeyMouse only works once the OS has been loaded.
I will try different usb ports and the handoff settings (if available) and I will report.
This is an old computer, Dell Latitude e6430s, this may be a good time to upgrade. I love this old computer, works flawlessly and it's quite fast with Linux.
1 year ago
I don't imagine BIOS settings or re-installation / recompilation would help if other USB keyboards work, that implies your handoff settings are fine or your Grub already supports HID devices. Either way, assuming you've tried the KeyMouse on the USB port that works with the other keyboard, I should think that would really narrow down the scope of the issue. Guess it could be some odd compatibility issue with the Dell, but even that seems unlikely if you can type on the KeyMouse after boot, unless the other keyboard only works while the KeyMouse is disconnected (i.e. the Dell chokes on the number of HID input devices constituted by the KeyMouse).
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below.
Supported: gif,jpg,png,jpeg,zip,rar,pdf
· Insert · Remove
  Upload Files (Maximum 2MB)
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.