Friday, 11 March 2022
  14 Replies
  0.9K Visits
  Subscribe
Hi,

I am trying to use the software to change key assignments and update firmware since I also suffer from the blue fn scroll issue which is fixed on the new beta firmware but i am running into anissue where the software says it cannot connect to the device and to check the log.

Also i can only see the right device from the software when trying to save but on a youtube video i saw left and right showing. Not sure which is correct. I connected the right with the provided cable and even tried connecting both but only one showed.


any advice? also where is the log?

Thank you!
3 months ago
·
#3022
Hi Brett. We have not yet developed macros on the hardware itself. The macros are not able to save to the device as of right now. We currently are using software-level macros, which require the software to be open. We plan to save the macros to the device itself in the future so the macros can work without the software.
3 months ago
·
#3020
Hey there I think I have misled you here. I guess what I am having problems with is the macros on the layouts, when I say the layout is not saying. In the first attachment that you sent, I have that on both devices when I save to the device for the layouts. So it seems that when the software is running the macros work fine but when I have it off they don't work at all. The only difference is that the software is running. The second photo is of the firmware not sure if what I have is correct as seeing your photo is different. Thanks for the help
3 months ago
·
#3018
Hi Brett. As stated above, only one hand will show up when programming the devices if they are plugged into the computer correctly. Did you plug only the left-hand device into your computer and set which hand it is by using the firmware update tab?

Keys such as FN blue etc. will not work properly between devices if they are not both connected to each other via serial port with a USB mini to USB mini cable (cable connected into the right port looking from the top on both devices)

When you say you are having problems saving to the left KeyMouse, is it not assigning keys properly or is it not showing the "Other hand - Detected" in the log when saving to the KeyMouse devices?

When you have the software running in the background, what is different about the key layouts than when you aren't running the software. The devices shouldn't be using the software as all the layouts are stored on the device memory.
3 months ago
·
#3014
I'm having problems saving key layouts to my keymouse. I plug the right keymouse into the computer and the left is the slave. I'm having trouble getting the left keymouse to save layouts to it. I have tried to connect the left to the computer and save the layouts that way but still no luck after I reconnect the right back to the computer. However, it seems that when I have the software running in the background the key layouts seem to work.
5 months ago
·
#2955
Excellent! I'm glad you got it working. Thanks for sharing how you solved this issue.
5 months ago
·
#2954
Thank you for your replies!
Yeah the message on the application should prove very useful for new users like me.

I figured out the Windows 11 issue. Now that I knew what I was looking for it was much easier to pinpoint.
For me, it was my motherboard software loading on windows startup (Aorus Engine) for Aorus x570 pro.

Closing that app entirely from the taskbar allows me to save configuration to the devices normally.
5 months ago
·
#2951
Since the computer only sees the devices plugged directly into the computer, we're thinking to add a message to clarify for users something like in the attached screenshot. The software doesn't know if the "other hand"/slave device is plugged into the master device until it has opened the connection to write to the master device. We could potentially "detect" the slave plugged into the master when the dialog first opens, but it would hang the devices for a second or two when the dialog first opens while it connects to the devices to detect. For now, this message may at least help clarify for users.

Previous 100 series KeyMouse Devices actually had a USB hub in each hand, so the cable between the left/right hands essentially caused the computer to see 2 separate devices. The new devices intentionally cause the computer to see 1 "device", and the cable connecting the 2 hands is technically a serial connection for the slave to relay data through the master to the computer. This is to avoid avoid a lot of compatibility and sync issues for the computer (particularly on Mac where pressing modifier keys on one keyboard will not affect keys pressed on another keyboard).
5 months ago
·
#2949
Hi Dimitris. As stated above, only one device shows up in the software on the newer 300 series devices because the computer only sees one device, and the other device relays through the device connected directly to the computer. We have had issues with some users not being able to program their devices on Windows 11. We think it may be some security setting as you mentioned that is enabled on some Windows 11 machines. We have tested on Windows 11 and we also do not encounter the issue.

The log is in the screenshot you showed right below the progress bar. Basically, Windows is not letting the software connect to the device, probably due to some anti-virus software or Windows Defender blocking access to open the device.
5 months ago
·
#2947
Thank you, I understand that you are also a customer I am just posting for whenever someone from support checks it.

It is helpful that it works for you in win11. I wonder what i have different. Perhaps some security feature. I will test.

Thank you!
5 months ago
·
#2946
Dimitris,

I'm just another Keymouse customer/user so I don't know much behind the scene in term of software.

But a data point for you I am also using the KeyMouse software on Win 11 and does not encounter the same issue.
5 months ago
·
#2945
It is the windows 11 that is causing an issue. I just flashed the device just fine and adjusted key mappings on a win10 machine.

How can we resolve this? Can I help somehow?

Thank you
5 months ago
·
#2943
I cannot flash firmware either.

Tried multiple usb ports, run software as admin, compatibility mode, reconnecting devices.. nothing.
Any ideas?
Attachments (1)
5 months ago
·
#2942
Hey cb,

Thank you for your reply. It does help clarify some of the things however, I am still having trouble saving any configuration to my device. I am on Windows 11 and this is what I see (runs as administrator by the way)
Attachments (1)
5 months ago
·
#2941
Hi Dimitris,

The older KeyMouse shows both left and right in the software.

Currently the new version only show the side that is connected to the computer.

However the latest software does allow to save key layout to both side even though only one side is connected which is a time saver. For firmware upgrade I still have to plug in and upgrade each side individually.

Hope that helps,
  • Page :
  • 1
There are no replies made for this post yet.
Be one of the first to reply to this post!
Submit Your Response
Upload files or images for this discussion by clicking on the upload button below.
Supported: gif,jpg,png,jpeg,zip,rar,pdf
· Insert · Remove
  Upload Files (Maximum 2MB)
Captcha
To protect the site from bots and unauthorized scripts, we require that you enter the captcha codes below before posting your question.